Results 1 to 4 of 4

Thread: Tripod stabilizer.

  1. #1
    Chief Administrator 7.62x39's Avatar
    Join Date
    Feb 2004
    Posts
    6,517
    Feedback Score
    10 (100%)

    Default Tripod stabilizer.

    I assume most of you belt fed guys are familiar with Rich (1919_4_me) from the 1919 forum. He makes some real nice stuff for the 1919 and M2.

    I have been using one of his MG42 AA pod adapters and T&E setups. They are both first class rigs that work perfectly.
    He recently introduced a new product, a stabilizer kit for the MG42 tripods. Since I was one of the first to receive one, there is very little info on them yet, in the way of reviews or instructions. So here goes.

    The fit and finish is superb, just like his other products. In fact the fit is too good from my experience. While the individual parts assemble quite nicely, I found that when connecting them together, they fit together too tightly to allow enough tolerance to fit the variables from tripod to tripod.

    This may be something I'm doing wrong, but I can't see how. Theoretically you should be able to just pull the pins and fold up the pod.
    On mine everything fits so tight, it requires a large drift punch, 1lb dead blow hammer, about a half hour of coercing and a little cussing to get the pins in. Far too much effort for a portable shooting platform.

    It appears that if I open up the holes in the clamp part a tad and bevel the ends of the adjusters where the pins go through a little, I could gain enough wiggle room, to allow it to be broken down and set up with ease. The adjusters would then allow you to take out any slop.
    I'm not going to do any drilling or grinding until I get a chance to talk with Rich, as I said it may be something I don't have set up correctly. I'd bet the stabilizer fits whatever pod he used for mock up, perfectly, but I doubt the legs of these pods are held to any strict tolerances.

    I will say that once this kit is installed, the pod is rock solid.
    Attached Images Attached Images
    .

  2. #2
    Chief Administrator 7.62x39's Avatar
    Join Date
    Feb 2004
    Posts
    6,517
    Feedback Score
    10 (100%)

    Default

    PS Rich also has his own 1919 forum.

    http://www.shoot1919a4.com/
    .

  3. #3
    Chief Administrator 7.62x39's Avatar
    Join Date
    Feb 2004
    Posts
    6,517
    Feedback Score
    10 (100%)

    Default

    I got a reply from Rich


    7.62,
    Yea the AA Stabilizers are sometimes a little hard to put on for the first time.When you first put these on I usually measure down the legs to @ 5.00' inches.I'll install the mounting clamps on to the AA Leg and leave them semi tight to where you can still rotate them a little (all 3 clamps).Next you want to adjust the legs to where they are spread evenly and to where your comfortable with the height.
    Next you want to take one of the adjusters and put it into one of the clamps.Slide the 5/16's clevis pin through.Next slide the other side into the clamp and turn the adjuster until it starts to line up with the other hole.You will have to rotate the clamp slightly so you can put the other 5/16's clevis pin in.Once 1 side is on adjust the AA leg to where it pushes it out.
    Repeat this process to the other 2 AA legs.*Note on the last leg it will be a little hard to get the pins in but once there in you want to tighten the adjusters to where there (Pulling) the AA legs in.You want constant pressure on the legs to it will make it rock solid.

    7.62,
    As far as the holes being really tight for you I always run a 5/16's drill through them to clean up any paint residue so the clevis pins should slide through pretty easy.Once you get to know the AA stabilizer on how it adjust's and fits it will only take a minute or so to take it down for storage.Remember once your clamps are tightened they should always stay on your AA for storage and only the adjusters will come off.
    I am definitley going to take some pics of a full install as soon as I can.Maybe even a video is in order.These can be tricky but it basically comes down to where you just have to play with it a little and it will go right on.
    Hope these pics help a little in the fit up.




















    Let me know if you have anymore question on these. 8)
    .

  4. #4
    Chief Administrator 7.62x39's Avatar
    Join Date
    Feb 2004
    Posts
    6,517
    Feedback Score
    10 (100%)

    Default

    My clamps must be very close to the same location as in your pic. Mine measure 6" from the little rib on the top of the leg, which is just visible in your first pic.
    From looking at your pic it appears that the rib is a little more than an inch above where you are measuring from, so I may have to adjust the height a little.

    The problem I seem to be experiencing was from the tight fit between the eye of the adjuster (where the clevis pin slides) and the clamp itself.
    The fit is so precise (which would normally be a good thing) it does not allow any lateral movement. I figured if I beveled the ends of the eye slightly it would give me enough wiggle room to make it a lot easier to assemble.
    Snugging the adjusters should lock it up solid once it's installed.
    Don't get me wrong, I don't think there is anything wrong with your design or fabrication. I just think it needs a little looser tolerance to work on a multitude of pods (or at least mine)

    I'll play with it a little more and get back to you.

    PS thanks for the quick reply
    .

Search tags for this page

There are currently no search engine referrals.
Click on a term to search our site for related topics.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •