Results 1 to 7 of 7

Thread: cobra sight

  1. #1
    Gunco Rookie davidn3's Avatar
    Join Date
    Feb 2009
    Posts
    7
    Feedback Score
    0

    Default cobra sight

    how do you put the sight on the side mount. it didn't come with instructions and i can't figure it out

  2. #2
    Chief Administrator 7.62x39's Avatar
    Join Date
    Feb 2004
    Posts
    6,403
    Feedback Score
    10 (100%)
    .

  3. #3
    Gunco Rookie davidn3's Avatar
    Join Date
    Feb 2009
    Posts
    7
    Feedback Score
    0

    Default

    ok. Thanks. I got it mounted. And I had to adjust the dials all the way to the right and to the top. I even took the lock nuts on the dial off and adjusted the screw all the way. and it still seem like it needs to go more. has anyone had this problem before?

  4. #4
    Chief Administrator 7.62x39's Avatar
    Join Date
    Feb 2004
    Posts
    6,403
    Feedback Score
    10 (100%)
    .

  5. #5
    Gunco Rookie davidn3's Avatar
    Join Date
    Feb 2009
    Posts
    7
    Feedback Score
    0

    Default

    I did all of that. I have it far as it will go to the right and the it lines up about in the middle. But it is far as it will go up and still needs to go more. I think the sight might have been dropped or the laser is messed up or something.

  6. #6
    Happy Camper hcpookie's Avatar
    Join Date
    Feb 2004
    Location
    Williamsburg, VA
    Posts
    7,653
    Feedback Score
    3 (100%)

    Default

    Or more likely the sight rail is not 100% aligned with the barrel. I had that problem on my PSL and had to remove and reinstall the rail. NOT FUN.

    You can probably get away leaving the rail alone and shim the sight mount with a sliver of a trimmed soda can. "needing to go up" sounds like you should shim the FRONT of the sight mount.

  7. #7
    Gunco Rookie acem's Avatar
    Join Date
    Dec 2006
    Posts
    18
    Feedback Score
    0

    Default

    My ORF AKS74 has a rail installed by them. The rifle is great but the rail is soo crooked I can't get my kobra to zero. It needs to be removed and reinstalled. Thx-Ace

Search tags for this page

There are currently no search engine referrals.
Click on a term to search our site for related topics.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •