Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15

Thread: charge bolt on rpd

  1. #11
    No Hope For Me Coils's Avatar
    Join Date
    Feb 2005
    Location
    PA Where the Amish Roam Free
    Posts
    13,980
    Feedback Score
    38 (100%)

    Default

    What he said about the butt stock door, it rotates.


    To field strip it, your right about the pin that holds the lower on. If I remember right, it's a stock pin that has a screw added to one end, you need to remove the screw then knock out the pin. Oh and make sure the striker is in the forward position, the fired position.
    After you get the pin out the lower slides off, then pull on the charging handle to get the bolt & striker to come out of the receiver.
    "Government is not the solution to our problem, government is the problem" Ronald Reagan

  2. #12
    Gunco Rookie blackcpull's Avatar
    Join Date
    Mar 2011
    Posts
    6
    Feedback Score
    0

    Default

    Hi,

    I just got my RPD today and for some reason I can't get the bolt to go back at all. Any tips? Thank you.

  3. #13
    Gunco Member agriebel's Avatar
    Join Date
    Feb 2011
    Posts
    53
    Feedback Score
    0

    Default

    It takes more effort than you would expect. Better after it gets broken in.
    you can see in this video it takes a little more grunt.

  4. #14
    Gunco Member THECARREAPER's Avatar
    Join Date
    Mar 2011
    Posts
    93
    Feedback Score
    0

    Default

    wish I had seen this thread. i called Stan like an idiot, thinking the gun was jammed! Takes ALOT of grunt to open the thing, but it will break in. I sat there in the gun room and open /closed it about 5000 times . its getting better!

    ps i loaded all my ammo wrong. the little clip goes on the base of the round, not IN the extractor groove. Now I have 4 belts to reload. Still very, very happy with my short, suppressed RPD !

  5. #15
    No Hope For Me Coils's Avatar
    Join Date
    Feb 2005
    Location
    PA Where the Amish Roam Free
    Posts
    13,980
    Feedback Score
    38 (100%)

    Default

    ps i loaded all my ammo wrong. the little clip goes on the base of the round, not IN the extractor groove.
    That depends on the type links you are using, there are two styles, one goes into the extractor groove and the other goes onto the base.
    Go here, I can't get them to upload here for some reason.

    http://www.arizonaresponsesystems.co.../rpdlink01.jpg

    http://www.arizonaresponsesystems.co.../rpdlink05.jpg
    "Government is not the solution to our problem, government is the problem" Ronald Reagan

Page 2 of 2 FirstFirst 1 2

Search tags for this page

There are currently no search engine referrals.
Click on a term to search our site for related topics.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •