Gunco Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
hello i have an sar 1 with amd 63 furniture and when i am tring to bump fire it some times the fireing pin just barely touches the primer and the shell dosent go off this happens rather often even when rapid fireing. I tried a new bolt and bolt carrer but it still does it. This can be rather flusterateing any of you guys out there know what i am talking about or have had this happen to them????
i have also replaced the fire control group
 

·
Premium Member
Joined
·
5,980 Posts
The "barely touching the primer" is the normal mark a round gets when chambered.

I'm assuming a hammer is against the bolt when it stopped firing. What may be happening is that the hammer is following the carrier foreword.
 

·
Registered
Joined
·
4,077 Posts
what he said ,,,,,,, look carefully at your fire controle group and be shure they are working properly and not worn
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
hotbarrel said:
what he said ,,,,,,, look carefully at your fire controle group and be shure they are working properly and not worn

that was the problem i had a bad sear spring
thanks for the info it workd great now
 

·
Registered
Joined
·
4,077 Posts
I am realy happy that worked out for you. just a note I put in a home made spring their and it worked ok for about 100 rounds then I got slam fire and missed fire too. .. not good .. oh well live and try to learn.
BUMP AWAY and let the lead fly.
 
1 - 5 of 5 Posts
Top