Gunco Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
ok as some of you have seen i bought a vulcan receiver well i did some test fitting and no problems got the front trunion in place all went smooth positioned the rear trunion all is ok installed the fireing pin and bolt all is ok still insert the mag did the proper clearence but when the mag is incerted the bolt will not pull back and will not load ammo properly whayt is my issue also anybody know of a good place to see how to install the trigger group and where do i have to trim the ejector on the vulcan receiver
thanks for any and all help andrew
 

·
Registered
Joined
·
12,413 Posts
Just off the top of my head it sounds like the mag is too high in the receiver.

Stupid question, but I have to ask.

Did you install the plate under the magazine catch/release part of the trigger gaurd?

If that was missing the mag would insert about 1mm higher in the receiver and possible interfer with the bolt. Don't mean to make you sound like a rook, it just popped into my head.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #3 ·
ok well i found 1 mistake i was just cycling the bolt with no trigger guard in place so i installed it and i seem to be hitting the mag on the rt side it will cycle if i force it but its not right any help guys thanks

andrew
 

·
Registered
Joined
·
1,681 Posts
Almost all of my hang up and failure to function are because the ejector is not trimmed back enough, if it's too long then the ejector will push the bolt to the right and cause a jam either on the mag feed lip or the other rail
 

·
Premium Member
Joined
·
6,900 Posts
yugosks71 said:
ok well i found 1 mistake i was just cycling the bolt with no trigger guard in place so i installed it and i seem to be hitting the mag on the rt side it will cycle if i force it but its not right any help guys thanks

andrew
Back to Sang's original question.
Did you install the selector stop under the TG?

Does the bolt cycle properly without the mag in place?

You really should have the TG/SS secured in place before mounting the trunnion, to ensure proper mag fit.
 

·
Registered
Joined
·
561 Posts
It sounds like the ejector is canting it, locking up the charging handle/bolt.
Most of the "Vulcan" receivers are made to fit the 74 and the 47. I had to trim two of them. You're also lucky that the trunions lined up with the holes in the receiver. Both vulcans that I've built on, I had to alter the holes and the mag wells also. If it's a "Vulcan" Don't forget to heat treat the rails and pin holes.
Hope this helps,
-Shadow-
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #7 ·
do i just trim by hand or is there a measurement to go by i also could not find the trigger group instructions so any help there would be great

thanks andrew
 

·
Registered
Joined
·
3,518 Posts
Just start trimming up where it is rubbing. You should see where it is grinding some paint from. A couple of my builds went that way as well.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #11 ·
ok so i got the bolt to cycle properly now i just need to fid a write up on the fcg and all will be good anybody know of a place thanks guys for all of the help

andrew
 

·
Registered
Joined
·
561 Posts
For the F.C.G try "Redstararms.com". If you have a new U.S. G2 made fcg then those are pretty simple, you can assemble it before installing. If you are using the one that came with the kit you may have install in this order. Trigger,selector,spring, disconnector then pin.
-Shadow-
 

·
Registered
Joined
·
1,681 Posts
yugosks71 said:
ok so i got the bolt to cycle properly now i just need to fid a write up on the fcg and all will be good anybody know of a place thanks guys for all of the help

andrew

WAs I right? Sounds like I was right.....I'll be damn
 
1 - 16 of 16 Posts
Top